Setting Up Firmware: Mac Platform


Mac Platform: Choosatron Firmware Setup

  1. If your Spark Core and Choosatron are assembled. Take it apart. It’s going to be easier. You want your Spark Core separate from the main PCB, or at minimum access to the two buttons on the Spark.

  2. Install Homebrew (scroll to the bottom for instructions).

  3. Install DFU-Util with this command:

brew install dfu-util

  1. Navigate to where you downloaded and unzipped the firmware and flash files (here is the download link again: cdam-v100-firm&

  2. Plug a USB cable from your computer, to the micro-USB connection on the Spark Core. Be gentle!

  3. Enter DFU mode by holding down both buttons and release the Reset button (on the left w/ USB port facing you). Wait until the yellow flashing. (visual reference here, or more detailed instructions on entering and verifying DFU mode here)

  4. Run the following command to flash the firmware:

dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -D choosatron-core-v100.bin

  1. It should take about a minute or less. If it takes you out of DFU mode, get back into DFU mode (see step 6).
  2. In DFU mode once again, run the following command to flash a set of 10 stories to play. (WARNING: This one takes 3-5 minutes, be patient.)

dfu-util -d 1d50:607f -a 1 -s 0x80000 -v -D choosatron-flash-09-kids.bin

  1. You will see LOTS of repeating messages like this:

Download from image offset 0017f400 to memory 001ff400-001ff7ff, size 1024
Poll timeout 30 ms
Poll timeout 0 ms

  1. Wait until it finally finishes in 3 to 5 minutes with this message:

File downloaded successfully

  1. The Spark Core will keep flashing yellow even when it is done. You may remove power (unplug from USB), or hit the small reset button.

  2. Put the Spark back into the main PCB if you took it out. Put it together in it’s case (or whatever form you want) and power it off (if not already). Then plug the main power in and wait. A short while later you will get a short print out that says “Press any button to start!

  3. Congratulations, it’s set up!

START HERE: Setting up a new Choosatron Kit!

I’m having flashing the spark core. I have unzipped the firmware and flash files, but when I run the flash firmware command in Terminal (step 7) it say it can’t find the file. I assume I have to modify the command line to define the location, but sadly I don’t know the syntax required. Can anyone help?

This is what I get when I run the command:

dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -D choosatron-core-v100.bin
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to

dfu-util: Could not open file choosatron-core-v100.bin for reading: No such file or directory


I’m not a Mac person, however where ever you have the DFU-Util, you need to have the bin file as well. It should work then.